Okay
  Public Ticket #2733075
Translation Single Room posts block
Closed

Comments

  •  1
    Stijn started the conversation

    Hi,

    I've been using your Hemma theme for a while now on my website https://maisonlegarochet.fr/

    Overall, I'm very happy.
    Just one issue with the translation of single room posts as block in the main page. You will see that when switching languages on the home page, the single room post isn't available in language English and Dutch. It is only available in French language.
    The reason is that I can't select the translated version of my Room in the single room post dropdown configuration menu. 

    However, the room is translated in every language and reachable through the direct links : 

    - https://maisonlegarochet.fr/room/gite-rural/

    - https://maisonlegarochet.fr/nl/room/de-vakantiewoning/

    - https://maisonlegarochet.fr/en/room/the-cottage/


    The root cause of the problem seems related with the room category not being saved for the translated versions English and Dutch. When saving, the room category is lost (check-box unchecked) again. See attachment.


    Thanks for your help. It is crucial to have this block on the homepage in all languages. More rooms are to come as well...


    Best regards

    Stijn Sanders


    Attached files:  RoomCategory.JPG

  •  207
    Pasquale replied

    Hey Stijn,

    You say "the single room post isn't available in language English and Dutch" but it's not what I see: https://www.loom.com/share/7b7a606880364e0dae58cd0a650fe444

    I am not sure to understand what the issue is, but it seems that only the Dutch page is not reachable, and that's likely due to something wrong with settings. Also consider that you don't really need to assign any categories to rooms, since they're not going to display anywhere in the front-end.

    Another tip: in some cases, re-saving permalinks (https://wpastra.com/docs/how-to-refresh-wordpress-permalinks/) might help to fix unexpected issues with redirects.

  •  1
    Stijn replied

    Hi Pasquale

    thanks a lot for your quick reply and tips. It didn't solve the problem with the single room post. 

    There was indeed an issue with the Dutch page, I did a restore and that should be fixed now.

    However, it is in my opinion not related to the issue I'm having with the translated version of my room in the single room post.  I made a quick video to explain my issue. You'll find it here:

    https://www.loom.com/share/98315a8fdfd049ee9efeda2218ab2da4

  •  207
    Pasquale replied

    Hello again,

    Can you please set Polylang settings like in the attached screenshot and re-try?

    Thanks!

    Attached files:  Screenshot 2021-03-27 at 10.07.24.png

  •  1
    Stijn replied

    Hi,

    I tested it this morning and once again right now, but still the exact same behaviour after setting the Polylang settings as suggested...

  •  207
    Pasquale replied

    Are you having issues with assigning categories only? May I ask why you are trying to add categories to rooms?

  •  1
    Stijn replied

    I'm currently only having issues with the category and with the dropdown list of available rooms in the "Single Room Post" block (language Dutch and English not available as explained).

    I don't need the category for anything else, seems just the default behaviour to have a category assigned to the rooms. Unchecking the category from the room configuration in the French language, didn't solve the issue either.

    Anyhow, I supposed that the issue of the dropdown list was related to the missing category on the translated Dutch and English rooms (assuming category is used to determine the listed elements) but this was only a guess and maybe both are not related at all..

  •  207
    Pasquale replied

    Hello again,

    TBH I still have not clear what the issue is.

    If you don't mind sharing your WP credentials in a private response, I'll be more than happy to have a look and see what's wrong.

    Best, P.

  •   Stijn replied privately
  •  207
    Pasquale replied

    Please uUse a fake email and provide me the username and passwordsmile.png

  •   Stijn replied privately
  •  207
    Pasquale replied

    Hey Stijn,

    I've checked out your dashboard but it looks quite a mess, it's plenty of pages and plugins. I didn't make any changes because I don't really want to feel responsible of breaking anything.

    Anyway, something is not working as it should because there are 54 pages and pagination does not display (screenshot).

    I can't say why it's happening, unless I make changes. You could try disabling the plugins that are not required by the theme, and see if the WP dashboard works again as expected. If you allow me to do make changes, I can do it for you.

    Attached files:  Screenshot 2021-03-29 at 18.04.06.png

  •   Stijn replied privately
  •  207
    Pasquale replied

    Hey Stijn,

    I've temporarily deactivated all non-required plugins, changed Polylang settings to make them match with my demos, and your website seems to be working now.

    Before continuing, I see that you are using a theme version from 2018. Did you purchase the theme on ThemeForest? If so, you are supposed to download the latest theme version from ThemeForest and update the theme as explained in the docs: http://docs.opendept.net/hemma/ (last chapter).

    Said that, please check that everything is working, then you can re-enable all plugins one-by-one and ensure they don't break your site again (please make sure that the pagination is still working after enabling each plugin: https://maisonlegarochet.fr/wp-admin/edit.php?post_type=page&lang=all ).

    Finally, I strongly recommend that you avoid bloating WordPress with so many plugins, or the site performance will be negatively affected. Use only the plugins your site really needs.

    Best, P.

  •  1
    Stijn replied

    Hi Pasquale


    Thanks a lot for your help.

    I just tested different functionalities and the issue is solved by your action.
    Yes, I bought the Theme from ThemeForest. I'll update asap as suggested.

    Hence I'll start reactivating plugins and manage them more carefully as to avoid further performance issues.


    Regards

    Stijn

  •  207
    Pasquale replied

    Cool!

    I was just asking to be 100% suresmile.pngit seems there are a couple of "nulled" pirate copies of this theme on the web, but they are malfunctioning and contain malwares/trojan that might damage a computer. The only authorised channel to get a valid copy of this theme is ThemeForest.

    Best, P.

  •   Stijn replied privately
  •  207
    Pasquale replied

    Can't you download the latest theme version? If so, I guess you should contact Envato...

  •  1
    Stijn replied

    exactly, no download available. Will do so...
    Thanks for your help.